PureRef Forum

Welcome, Log in or Register

I've been using this program for a while now. As an artist, I find this really helpful whenever I need some references for whatever I am drawing. However, one thing let to another, and now I'm utilizing a different computer, not much 'different' from my old one. I decided to download the program again, but this time it's not working how it's supposed to work. I have it on 'always on top', though it is blocking me from dropping any images on the canvas-I have no idea what the case may be. I mainly use Google Images to seek out references, and in my old computer, it'd work just fine, with no problems encountered. In this computer, howbeit, it does not let me drop down images. I make sure they're compatible to the program, and I have tried reinstalling it multiple times, but I just can't seem to fix the problem!

Is there anyone here that knows an answer to this issue?

(Utilizing Windows 9, which should be compatible with the program).
One reason why you might be unable to add images is if you have locked the canvas with the Lock Canvas (Ctrl+R) feature, could this be the case?
Oh, unfortunately that does not seem to be the case.
For more insight, whenever I hover the image i want to drop on the canvas. The mouse will turns into the 'do not' warning sign the moment it comes in contact with the canvas, and the clicked image will automatically go back to it's place on the window below. I uninstalled it a couple more times, played with the settings for a bit and see if I could manually fix it, but really... I've have had no such luck. I don't know what the issue may be, to be honest.
Does this happen for images from all sources? Drag drop from the browser and from disk? Can you copy paste the images or use the Load -> Load Images (Ctrl+I) in the right click menu instead?

You can try to completely remove the settings file located under C:/Users/<username>/AppData/Roaming/PureRef.ini

I know this is an ancient topic and I have seen there have been other similar topics over time but I seem to have this issue and am being unable to resolve it. I wanted to post in one of these old topics in case I manage to resolve the issue so others can find the solution too, as this topic was one of the top results.

Here's a breakdown of how the issue has happened for me and what I've done(Windows 10):

1. I downloaded the portable version of PR and started using it. Drag-and-drop and everything else worked fine. I was dragging images from my local files into PR.

2. Then I thought that maybe I was making a mistake by choosing to use the portable version, so I closed PR, downloaded the installer, installed it over the old location and started using it again and tried getting an image off my browser. At this point, drag-and-drop wasn't working anymore, not even from local files.

3. I thought that installing over the old files caused some issue. I uninstalled PR completely through Windows' control panel. Then I deleted the settings file in %appdata% and simply extracted the portable version again and started using that. That's the stage I'm in now.

At the moment, drag and drop still isn't working; I would like to provide a screenshot but am unable to capture the mouse but when I try to drag an image, either from my files or from my browser, the cursor changes to the "Illegal action" crossed O icon.

The other thing I have now noticed is that on the taskbar, PR no longer has the little buttons for transparent to mouse and overlay and so on, see this screen capture below:


Edit: For the moment I won't try anything else until there's a reply, so I don't change the situation again or add more variables into the problem.

Edited 1 time(s). Last edit at 2021-01-11 13:25 by ddner.
Hi. Sorry to resurrect an old thread, but this is something that happens to me, too. It seems very random. One minute, an image will drop into PureRef fine, the next - it won't. Or a particular image I've downloaded won't. I've recorded a GIF:


These images won't even load in Paint. They're usually fine in Photoshop though. Even if I re-export them out of Photoshop as a PNG, JPEG, or a PSD file, they still won't load. There have been occasions where they sometimes will, but it's very short lived and they suddenly don't again. I've even checked the Properties of the files and there's nothing that needs unblocking or anything.

I'm using Windows 11 on my laptop and Windows 10 on my PC.
The solution for me was that I had my firewall blocking PureRef - once I unblocked it dragged and dropped fine from the browser....

Edited 1 time(s). Last edit at 2023-03-26 10:30 by FletchNZ.
I'll give that a try the next time I'm on my PC. I suspect it is just my PC that has the issue as my laptop is perfectly fine; all the images display correctly. My PC keeps having weird issues, so I reckon that's the culprit. I mean, at the moment, Sleep mode won't even work on it lol.
Sorry, only registered users may post in this forum.

Click here to login