PureRef Forum

Welcome, Log in or Register
Just purchased but cannot move window at all. It's just dead center on monitor. Right click and drag doesn't work. As far as I can tell all other shortcuts work fine. The window nor canvas is locked. I'm on A mac running OS Mojave 10.14. Any suggestions.

Edited 1 time(s). Last edit at 2019-01-14 02:33 by 3dp.
We haven't experienced this issue ourselves unfortunately and it looks like you have tried the most obvious things. What type of input device do you use? You could try to reset the settings file but that should have been reset already since it was a new install. Does it help if you give another application focus and then go back to PureRef?
I had this problem as well.

Have you checked in Right-Click > Window and ensure Maximised isn't Checked.

(Try Cntl+F to toggle that on/off)
Thanks, JezUK. Maximized wasn't checked. But I've been able to move the window around by edge resizing to get it where I want it. Not optimal but that's what works.

I've found that PureRef has this problem only on my old (2010) Mac Pro, but works great on my 2013 Mac Pro. Thanks again for the reply.
I have the same situation.
Mac OS is Mojave 10.14.6

It always maximizes,And most shortcuts are invalid
CNTL + F become invalid
only can Undo (CNTL + Z)…….
We've tried to make some additional improvements in this area for the latest version, 1.10.4, if you give it a try please let us know if it works better!
Even more improvements to this are now available in 1.11.0, let us know if the issue persists!
Yes same issue here. I cannot move the window at all. I just downloaded the app on my mac. I am using Mojave 10.14.6.
Having the same issue as well. The window is just sitting in the middle of my screen. Everything else is functional except my ability to move it. Working on a 2009 4,1 flashed to a 5,1 Mac Pro.

Hoping there's some kind of runaround for this as I was really looking forward to using this piece of software.
I had the same problem!
I'm using a Wacom tablet and pen and I can move the window with the pen by hovering over the window + Click and Hold
hope this helps
We're looking into a rare issue where the UI seems to stop responding altogether on mac but we're still not completely sure what causes it as we can't reproduce it on our side. We've done some changes for the upcoming version of PureRef which we hope will help. If you're experiencing this issue any additional details you can think of would be helpful for us to hear!

If the above doesn't sound like your issue please try to explain a bit more what you're experiencing and we'll do our best to look into it! Don't forget to include what OS and OS version you're using. :)

@dcolpas: Just to make sure; right click drag / command + click drag doesn't function but everything else?
@Loubo1: Same question but it works with the pen only?
i have this problem also and Ive tried everything
So i was having the same issue but not in the beginning, in the beginning i couldn't move inside and through images but only with mouse.
i searched for some settings on trackpad so i won't have to use a mouse and i can move the window now.

Example: if you have set three fingers to drag a folder or a window this doesn't work here cause it's like selecting something.
Selecting the images when the '' canvas '' is not locked
when canvas is locked you can move not the window but panning through images

To move the window :
( if you have set the settings/accesibility/ pointer control/ trackpad options / enable dragging: three finger drag )
You have to click ( not tap ) the trackpad with 2 fingers on the window to move it and not with tapping with 3 fingers like on an ordinary folder or window.

This works on a locked or unlocked canvas as well !
У меня тоже эта проблема... У меня windows 10. Максимизация не отмечена, я проверила. Правой кнопкой мыши окно не перемещается!..
Mac Pro late 2013
MacOS Big Sur
Version 11.2.3
ctrl left clic = Mac right clic doesn't work. same problem, can not move the main window
I have solved my issue by preventing windows autonomous arrangements. https://thegeekpage.com/fix-maximized-window-wont-drag-problem-in-windows-10/
i have the same problem but im on windows 10
Sorry, only registered users may post in this forum.

Click here to login