PureRef Forum

Welcome, Log in or Register
Hello,

Once I enable the "transparent to mouse" mode the keyboard shortcuts stop working, and I can not disable it.

I tried selecting the PureRef app in the dock (or ALT+TAB to the PureRef) and then hitting the CTRL+T (the shortcut for "transparent to mouse") but the shortcut is not doing anything.

The PureRef app is the currently active app, but none of the shortcuts seem to be working in the "transparent to mouse" mode.

I am using Ubuntu 22.04, GNOME Shell 42.5, X11 windowing system



Edited 1 time(s). Last edit at 2023-03-07 16:04 by artbit.
artbit Wrote:
-------------------------------------------------------
> Hello,
>
> Once I enable the "transparent to mouse" mode the
> keyboard shortcuts stop working, and I can not
> disable it.
>
> I tried selecting the PureRef app in the dock (or
> ALT+TAB to the PureRef) and then hitting the
> CTRL+T (the shortcut for "transparent to mouse")
> but the shortcut is not doing anything.
>
> The PureRef app is the currently active app, but
> none of the shortcuts seem to be working in the
> "transparent to mouse" mode.
>
> I am using Ubuntu 22.04, GNOME Shell 42.5, X11
> windowing system

Thanks so much for creating a Linux version of PureRef! I really appreciate it! From playing around with the app, it works more or less flawlessly on Fedora Linux 38 with GNOME 44, but I also encountered the same issue with "Transparent to mouse" mode.

After entering "Transparent to mouse" mode, when I restore focus to the PureRef app by clicking "Activities" and then selecting the PureRef window, the app does not respond to the command CTRL+T to disable the mode.

The only way to leave the "Transparent to mouse" mode is to close the application and then reopen it.

I'm running PureRef version 1.11.1 via the AppImage.



Edited 2 time(s). Last edit at 2023-06-26 17:57 by AzureDusk10.
We've just released a beta version of PureRef 2.0 in which the default behavior is now to automatically disable mouse transparency on app activation. This behavior can be controlled with the "Disable mouse transparency on activate" setting. You can get it on the download page if you want to give it a try to see if it helps for you.
I've installed the beta, and the issue seem to have been fixed in the beta version.

Thank you for really caring about your users, and thank you for all the hard work.

Stay awesome!
Thanks so much for your work on this. On Fedora 39, I can now exit the "Transparent to Mouse" mode without closing Pureref, but it's not via the keyboard shortcut Ctrl + T like the dialog says.

I'm on the beta version 2.0.0beta5. When I enable "Transparent to Mouse" mode in combination with "Always on top" and "Overlay selection", the keyboard shortcut Ctrl + T doesn't do anything. However, I've found that I can exit this mode when Pureref window loses focus and then regains focus (i.e. I use Alt+tab or the Activities overview to focus away from Pureref and then back to Pureref). When this happens, "Transparent to Mouse" gets turned off automatically.

This behaviour makes sense to me and is definitely an improvement, but it doesn't match what is written in the dialog.

I hope that's helpful feedback



Edited 1 time(s). Last edit at 2023-12-17 03:39 by AzureDusk10.
True, the dialog should probably state the new behavior. Thanks for the feedback!
Sorry, only registered users may post in this forum.

Click here to login