PureRef Forum

Welcome, Log in or Register
Hello.

I'm on Mac, using PureRef 1.11.1, using a Belgian keyboard (azerty).

When I type Ctrl-Z on my keyboard in order to try to undo an action, it gets passed as Ctrl-W, which locks the window. And vice versa, when I type Ctrl-W, it does Undo. In the Settings > key binding, Undo is set to Ctrl-Z as it should.

I expect Ctrl-Z to get registered as Undo, like it says in the Settings.

Workaround: I have set Undo to "Ctrl-W", and lock Window to "Ctrl-Z". Now, when I type Ctrl-Z on my keyboard, it does Undo :-)

It would be nice if this workaround would not be necessary. Can you look into it?

There was another similar issue which was solved for the author, but it's not solved for me: https://www.pureref.com/forum/read.php?4,2127,2127#msg-2127.

Thanks a lot and have a good day,

Samuel
Hello,

I'm having the same problem on a Macbook Pro with french azerty keyboard.
Some shortcuts work like
Cmd + N
Cmd + F
Cmd + H
Cmd + J
Cmd + Shift + R
and the ones for saving and others.

These are not working properly :
Cmd + A and Cmd + Q : tries to quit.
Cmd + M : does nothing
Cmd + Z locks Window instead of Cmd + W
and maybe some others that I haven't found.

So it appears to be an azerty / qwerty problem.

It's my first time using Pureref, it looks gorgeous, but I feel a little limited with these problems.
Can you fix these ?

Regards,
R
This issue should be fixed in PureRef 2.0 which is available as a beta on the download page now if you want to give it a try! If you have rebound any shortcuts to make it work you might have to restore them to defaults in 2.0 for them to work again.
I confirm that Ctrl-Z works as expected in the beta 2 version on an azerty keyboard, with the default settings.

Thank you!
Sorry, only registered users may post in this forum.

Click here to login