Welcome, Log in or Register
I started using PureRef today, I created an entire library of images, and then for the longest time I was under the impression that flipping images doesn't work.

Then I tried again with a single image only, freshly imported from my hard drive, and suddenly the flipping worked!

So I figured out that the real reason is that as I was organizing my images, I applied "Normalize Size" to all the images many, many times and the engine internally scaled them down each time, and apparently beyond a certain limit after which flipping just doesn't seem to work anymore for some reason. So even though the selected image visually spanned my entire screen because I zoomed in onto it, internally its scale was so small that it prevented flipping from working correctly.

(I suppose it could be because of some internal geometric transformations that are employed for detecting the motion of the mouse relative to the image - and those maybe break down beyond a certain minimum scale ratio - possibly something like that.)

So the way I fixed it was to select all my images and scale them up multiple times. Super easy. And then the flipping finally started working :)

Btw, the internal algorithm of "Normalize Size" command seems to be behaving very strange, most notably it keeps shrinking the images down every time it's applied which indicates that there's something wrong with it and it's not stable.
Regardless of this shrinking issue, the results of "Normalize Size" are not what I would expect, the images don't visually appear to be scaled uniformly which I suppose is the intended purpose of the command. Maybe a complete rewrite/rethinking of the algorithm would be beneficial ;)
I don't know what the current approach is, but my intuition would be to equalize the area of all the selected images (after cropping), but it is definitely an interesting problem to tackle :)

Edited 3 time(s). Last edit at 2020-03-07 23:05 by PureRef.
Thanks for reporting this, and you're completely right in your analysis of the issue! We've made some changes to avoid these issues in 1.10, so please give it a try and let us know if you still experience issues.
Sorry, only registered users may post in this forum.

Click here to login